?

Log in

Windows/StrawBerry/Catalyst - Catalyst Web Framework
The elegant MVC framework

Andrei Chernov NanoGrid posting in  The elegant MVC framework
User: ru_catalyst (posted by nanogrid)
Date: 2010-12-08 08:28
Subject: Windows/StrawBerry/Catalyst
Security: Public
Приветствую.

Старый Mechanize ставится также с ошибками:

PETDANCE/WWW-Mechanize-1.60.tar.gz
C:\strawberry\c\bin\dmake.EXE -- OK
Running make test
C:\strawberry\perl\bin\perl.exe "-MExtUtils::Command::MM" "-e" "test_harness(0, 'blib\lib', 'blib\arch')" t\00-load.t t\
add_header.t t\aliases.t t\area_link.t t\autocheck.t t\clone.t t\cookies.t t\credentials-api.t t\credentials.t t\die.t t
\field.t t\find_frame.t t\find_image.t t\find_inputs.t t\find_link-warnings.t t\find_link.t t\find_link_id.t t\form-pars
ing.t t\frames.t t\image-new.t t\image-parse.t t\link-base.t t\link-relative.t t\link.t t\new.t t\pod-coverage.t t\pod.t
t\regex-error.t t\save_content.t t\select.t t\taint.t t\tick.t t\upload.t t\warn.t t\warnings.t t\local\back.t t\local\
click.t t\local\click_button.t t\local\failure.t t\local\follow.t t\local\form.t t\local\get.t t\local\overload.t t\loca
l\page_stack.t t\local\referer.t t\local\reload.t t\local\submit.t t\live\encoding.t t\live\wikipedia.t t\mech-dump\mech
-dump.t
t\00-load.t .............. 1/2 # Testing WWW::Mechanize 1.60, with LWP 5.836, Perl 5.012001, C:\STRAWB~1\perl\bin\perl.e
xe
# Test::Memory::Cycle is not installed.
t\00-load.t .............. ok
t\add_header.t ........... ok
t\aliases.t .............. ok
t\area_link.t ............ ok
t\autocheck.t ............ ok
t\clone.t ................ ok
t\cookies.t .............. skipped: HTTP::Server::Simple does not support Windows yet.
t\credentials-api.t ...... Use of uninitialized value within @_ in lc at C:/strawberry/perl/vendor/lib/LWP/UserAgent.pm
line 559.
t\credentials-api.t ...... ok
t\credentials.t .......... ok
t\die.t .................. ok
t\field.t ................ ok
t\find_frame.t ........... ok
t\find_image.t ........... ok
t\find_inputs.t .......... ok
t\find_link-warnings.t ... ok
t\find_link.t ............ ok
t\find_link_id.t ......... ok
t\form-parsing.t ......... ok
t\frames.t ............... ok
t\image-new.t ............ ok
t\image-parse.t .......... ok
t\link-base.t ............ ok
t\link-relative.t ........ ok
t\link.t ................. ok
t\live\encoding.t ........ ok
t\live\wikipedia.t ....... ok
t\local\back.t ........... 1/47 # Started http://localhost:54289/
t\local\back.t ........... 33/47
# Failed test '404 check'
# at t\local\back.t line 151.
# got: '500'
# expected: '404'
# $server404url=http://jogger:54298/
# $mech->content="500 Can't connect to jogger:54298 (connect: timeout)
# "
# Looks like you failed 1 test of 47.
t\local\back.t ........... Dubious, test returned 1 (wstat 256, 0x100)
Failed 1/47 subtests
(less 2 skipped subtests: 44 okay)
t\local\click.t .......... 1/9 # Started http://localhost:54467/
t\local\click.t .......... ok
t\local\click_button.t ... 1/19 # Started http://localhost:54471/
t\local\click_button.t ... ok
t\local\failure.t ........ 1/15 # Started http://localhost:54477/
t\local\failure.t ........ ok
t\local\follow.t ......... 1/22 # Started http://localhost:54480/
t\local\follow.t ......... ok
t\local\form.t ........... 1/13 # Started http://localhost:54487/
t\local\form.t ........... ok
t\local\get.t ............ 1/32 # Started http://localhost:54490/
t\local\get.t ............ ok
t\local\overload.t ....... skipped: Mysteriously stopped passing, and I don't know why.
t\local\page_stack.t ..... 1/16 # Started http://localhost:54498/
t\local\page_stack.t ..... ok
t\local\referer.t ........ ok
t\local\reload.t ......... 1/14 # Started http://localhost:54509/
t\local\reload.t ......... ok
t\local\submit.t ......... 1/13 # Started http://localhost:54513/
t\local\submit.t ......... ok
t\mech-dump\mech-dump.t .. ok
t\new.t .................. ok
t\pod-coverage.t ......... skipped: Test::Pod::Coverage 1.04 required for testing POD coverage
t\pod.t .................. skipped: Test::Pod 1.14 required for testing POD
t\regex-error.t .......... ok
t\save_content.t ......... ok
t\select.t ............... ok
t\taint.t ................ skipped: Test::Taint required for checking taintedness
t\tick.t ................. ok
t\upload.t ............... ok
t\warn.t ................. ok
t\warnings.t ............. ok

Test Summary Report
-------------------
t\local\back.t (Wstat: 256 Tests: 47 Failed: 1)
Failed test: 33
Non-zero exit status: 1
t\local\click_button.t (Wstat: 0 Tests: 19 Failed: 0)
TODO passed: 15-17, 19
Files=50, Tests=557, 230 wallclock secs ( 0.33 usr + 0.33 sys = 0.66 CPU)
Result: FAIL
Failed 1/50 test programs. 1/557 subtests failed.
dmake.EXE: Error code 255, while making 'test_dynamic'
PETDANCE/WWW-Mechanize-1.60.tar.gz
C:\strawberry\c\bin\dmake.EXE test -- NOT OK
//hint// to see the cpan-testers results for installing this module, try:
reports PETDANCE/WWW-Mechanize-1.60.tar.gz
Running make install
make test had returned bad status, won't install without force

C:\Users\can>


В результате - этот пакет считается недоступным и Catalyst - не ставится.
Post A Comment | 5 Comments | Share | Link






User: alexchorny
Date: 2010-12-08 11:25 (UTC)
Subject: (no subject)
судя по описанию ошибки в bugtracker'е можно просто пропустить тесты - ошибка в самом тесте.
Reply | Thread | Link



Andrei Chernov NanoGrid
User: nanogrid
Date: 2010-12-10 09:13 (UTC)
Subject: MS Windows Vista
При установке Под Windows (у меня Vista, BTW) проявляется какая-то нестабильность:
- то не ставится один пакет (причем все его доступные версии)
- то другой.
- иногда помогает перевызов системы
- периодически пытаюсь почистить registry, но там ничего нет

Использую опцию у скрипта cpan -fi
Все равно Тесты пытается прогнать...
Вроде help/man по cpan изучал, как-то не нашел рекомендуемого no_test
или чего-то подобного.

BTW, сейчас не ставится Net-Server, версия 0.99
Воюю пока, но склонююсь уйти все же в чистый Линух или поднять Ubuntu под VirualBox
(опять же Sun/Oracle, что приятно ;-)
Reply | Thread | Link



Shoorick
User: shoorick
Date: 2010-12-17 11:15 (UTC)
Subject: Не только под виндой
Под FreeBSD 8 и Ubuntu 10.10 — аналогично.
Reply | Thread | Link



User: rozuumbo
Date: 2011-04-14 14:07 (UTC)
Subject: (no subject)
I don’t bookmark sites but i will bookmark this! LOL!

Reply | Thread | Link



User: warrenigyv
Date: 2011-11-03 07:21 (UTC)
Subject: (no subject)
Thanks for your share! very impressive!

Reply | Thread | Link



browse
my journal
links
June 2011